[daip] confusion

Eric Greisen egreisen at nrao.edu
Tue Jul 3 15:54:26 EDT 2007

Mike Bell writes:
 > so i've made some progress, i guess you might call it that.
 > now i log in to the server (galaxy) via ssh

   after you do this type

printenv | grep SSH

 > then i run aips using
 > aips tv= (which is my workstations ip)

    It should be able to do this by name.

 > it prompts for my password, which i enter, but keeps returning with
 > 'permission denied'

    This means that you have not set yourself up to log in between
machines without a password.  This may cause a variety of problems.

The permission denied raises another question or 3 - are you the same
account and group on the two machines?  Is that account and group
allowed execute privilege on files that need executing?  I would
suggest a whole bunch of echo statements be put in the START_AIPS and
STATR_TVSERVERS procedures in $AIPS_ROOT.  Also make a copy of
$SYSUNIX/XASERVERS in $SYSLOCAL and add echo statements in there too.
Be sure to add some $HOST's in the echos since the remote business.

Before you do all this - start aips on circular (or whatever
workstation you are on).  Then on galaxy say aips tv=circular tvok.

The really hard part is getting a remote machine to execute

Eric Greisen

 > outside of aips i can ssh from the server to my workstation just fine.
 > am i following the wrong procedure?  i've tried searching through the
 > cookbook, homepage, managers faq and can't find any info about using a
 > remote aips machine other than that i have to edit the HOSTS.LIST file,
 > which i think i've done properly.

More information about the Daip mailing list